Page 1 of 1

How to update PB on Unix?

Posted: Wed Jul 29, 2020 8:31 am
by inf3rno
I try to run the game on FreeBSD in Linux compatibility mode. The game starts, but whenever I connect to the server I am kicked with 20004 itegrity bullshit. I tried to google it, it looks like I have to upgrade punkbuster, which is an issue, since evenbalance no longer supports ET and I guess I'd need a very old version of punkbuster. Is there anybody who solved this on Linux or BSD? (Just wondering why we need punkbuster, because it is totally useless against cheaters, but makes the game laggy asf and kicks people with normally installed ET.)

Re: How to update PB on Unix?

Posted: Wed Jul 29, 2020 9:09 am
by inf3rno
I tried to upgrade it, now I got itegrity violation 20006. What a progress...

Re: How to update PB on Unix?

Posted: Wed Jul 29, 2020 9:37 am
by c0rnn
Try to install from a file here: http://download.hirntot.org/

We need PB for our ban system, it's not useless for us.

Re: How to update PB on Unix?

Posted: Wed Jul 29, 2020 5:35 pm
by evirdrevo
you can try asking chaplja, he also made some fixes to make et run on linux without problems

https://github.com/chaplja

Re: How to update PB on Unix?

Posted: Thu Jul 30, 2020 12:25 am
by inf3rno
c0rnn wrote:
Wed Jul 29, 2020 9:37 am
Try to install from a file here: http://download.hirntot.org/

We need PB for our ban system, it's not useless for us.
Not sure which one is Linux compatible. I found only exe files in the pb related zips.

Re: How to update PB on Unix?

Posted: Thu Jul 30, 2020 12:25 am
by inf3rno
evirdrevo wrote:
Wed Jul 29, 2020 5:35 pm
you can try asking chaplja, he also made some fixes to make et run on linux without problems

https://github.com/chaplja
Thanks, I will.

Re: How to update PB on Unix?

Posted: Thu Jul 30, 2020 3:38 pm
by c0rnn

Re: How to update PB on Unix?

Posted: Mon Aug 03, 2020 9:17 am
by inf3rno
It writes that "/bin/sh: pbsetup.run: not found" or if I run it as root, then it writes "pbsetup.run: Command not found". I guess FreeBSD does not contain everything that Linux does. I'll try with daredevil's files, maybe it works with that.

I copied the files from the first link, now it works. I have other issues too, but I'll post those in a different thread. Thanks for the help!

Re: How to update PB on Unix?

Posted: Wed Aug 05, 2020 2:31 pm
by a domestic cat
inf3rno wrote:
Mon Aug 03, 2020 9:17 am
/bin/sh: pbsetup.run: not found
That's an executable binary, are you sure you are running it correctly? Looks like an error message from shell (and bash in case of root, I guess). You should chmod +x pbsetup.run and then just run it with ./pbsetup.run.