Page 1 of 1

fps drops

Posted: Thu Jan 03, 2019 11:41 pm
by s0nic
Hello, a few days ago i started experiencing unstable fps, no matter what it's capped to.
Gpu is working fine and it runs way newer games on 100+ fps.
When i switch mods on et and it restarts, theres a strange graphical glitch, the colors are all scrambled for like half a second.
Things i've tried:
-older gpu driver
-newest gpu driver
(done clean installs, wiped old drivers, basically tried everything)
-messed around with ingame settings, reset everything to default
-r_primitives 0,1,2
-reinstalled et
-reverted custom reso back to 60hz
-reset driver multiple times via cru
-messed around with nvidia settings


still my fps runs like crazy anywhere around 105-120 when capped to 125, sometimes it syncs for no reason to 60/75 depending on what refresh rate i run. VSYNC IS TURNED OFF THIS WHOLE TIME.

there were no recent windows updates and no driver updates, it just randomly started happening.

i'm running out of ideas and patience, anyone has any suggestions?

Re: fps drops

Posted: Fri Jan 04, 2019 7:07 am
by crUx
ET relies very much on CPU too. If you have multicore processor, try to set it to not very used affinity. You also could use task manager and ET minimizer to check if CPU loads don't get too high while you play ET.

Re: fps drops

Posted: Fri Jan 04, 2019 11:05 am
by s0nic
First thing i noticed when i looked at resource monitor was that my idle cpu usage was ~50%.
Turned out it was some malware injected into a win process.
Funny how newer games don't make a big deal out of having only half cpu power available to them.
Thanks for pointing me in the right direction cruxie <3

Re: fps drops

Posted: Sat Jan 05, 2019 5:19 pm
by Ammo_please

i have the same problem 2 times /vid_restart helps for me.


Re: fps drops

Posted: Wed Jan 09, 2019 11:01 pm
by fishy'
if you play other mods i suggest you do /cvar_restart and exec cfg again, you can also try set this 2 process to run as admin, PnkbstrA and PnkbstrB, right click on process in task manager and click open file location, set both as admin rights. might solve, i always do it.